Monday, July 28, 2008

VM Server cannot connect to network after restore from save state

Ok, I know I am a bit off topic here, but we all use VMs, Right?

So let me start by congratulating MS for their Win2k8 64bit Hyper-V server (Amazing!), but for most of us we still use the Virtual Server on Win2k3, right?

Well, after installing the SP1 for the virtual server R2 i started having this problem:

I Saved state of my machine
Restarted the server (host)
Resumed the virtual machine and boom - the virtual server service halt and crashed, and after manually starting it i got an error starting virtual network connection and no more network for that machine...

Here is the error message:
The virtual machine cannot connect virtual network adapter 1 because another virtual machine with the MAC address is already running. This virtual network adapter will be left disconnected.

Only solution I found (worked some times) was to restart the server, start another machine first (dummy one i dont use) stopping it and than i had a 60% chance that the problem was solved for that session.

Now, for my network I have to use Static MAC address for network cards so i cannot change the MAC address on the VMs.

Today I found a new solution for that issue:
I went to the network card where the virtual network is connected, clicked properties, and unchecked the "virtual machine network services".

I clicked OK, waited for things to proccess my change, and than went back in and checked it again.

And what do you know? Things started to work again - no restart... no removing the virtual machine...

Well, hope it helps you guys, I seen a lot of posts on this but none reported a solution like that.

Shai.

2 comments:

Bravo said...

Thanks a lot! It didn't help but still now I have a clue at least.

David said...

Thank YOu. That was just what I needed. It fixed my problem.